Grace Guide

From Storrs HPC Wiki
Jump to: navigation, search

X11 GUI required

Grace is a free 2D plotting programfor linux. It needs X11 GUI to support the interaction. The details about how to run the X11 applications are available at X Apps.

Module required

The grace depends on following modules:

intelics/2013.1.039-compiler
motif/2.3.4
libjpeg-turbo/1.1.90
libpng/1.2.12
zlib/1.2.8-ics

To load the module, just issue the following command:

module load intelics/2013.1.039-compiler motif/2.3.4 libjpeg-turbo/1.1.90 libpng/1.2.12 zlib/1.2.8-ics grace/5.1.23

Or shorter version:

module load intelics/2013.1.039-compiler motif libjpeg-turbo libpng zlib grace

Examples

Grace provides some examples in /apps/grace/5.1.23/grace/examples. To run the examples, just issue:

cd /apps/grace/5.1.23/grace/examples
./dotest